I have to sign on an FTP server via a batch process. The FTP server has a password with a special character within it. The FTP log shows the following text after the password
> xxx***
Subcommand 'xxx' not valid.

(above xxx represents the first portion of the text of the password, the first * is where the special character is, and the last two of the characters display as asterisk also)

In the TXT source member, I tried enclosing the special character with a single quote, by two single quotes, by double quotes, none of which worked. I tried changing the special character to its hex value with a % symbol before the hex value. I've tried putting the userassword in the RMTSYS parm within the CL FTP command. That did not work.

Does anyone know of a method of signing onto an FTP server from an iSeries when the FTP server requires a password which has a special character within it? I asked the company if they could change the password for us, but they said they use the same password for all their customers. I don't know if they are FTPing from systems other than an iSeries though.

Thank you,