Unconfigured Ad Widget

Collapse

Announcement

Collapse
No announcement yet.

Printing from OS400 to Red Hat Linux V9 using cups

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • B.Kline
    replied
    Printing from OS400 to Red Hat Linux V9 using cups

    You're welcome. I'm happy to help.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Printing from OS400 to Red Hat Linux V9 using cups

    Have a linux server running Red Hat Ver 9 with cups. Windows clients print fine. However, printing from the As400 is the issue. Our As400 is an iseries model 810 running OS400 V5R2. I have another print server, without cups, also running Red Hat 9 and the AS400 prints just fine to those printers. I have set up the remote outqs the same as the ones that work with the linux box without cups, except of course for the different outq, rmtsys, rmtprtq. I keep getting a 'bad request line' on the linux box with cups and the status of my spool file on the As400 stays at 'SND' and nothing prints. I have been reading everything I can get my hands on to resolve this and have been unsuccessful. I have scanned numerous message boards and encountered similar problems posted -- still waiting for a reply. Any assistance on this issue would be greatly appreciated. Thanks. Frustrated

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Printing from OS400 to Red Hat Linux V9 using cups

    Well Barry, We are all extremely appreciative of all your time and effort in trying to help us resolve this issue. We are now printing from our AS400 to the Linux server using cups. A million thanks.

    Leave a comment:


  • B.Kline
    replied
    Printing from OS400 to Red Hat Linux V9 using cups

    I have attached my configuration.
    Code

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Printing from OS400 to Red Hat Linux V9 using cups

    Barry, Prior to the configuration I sent you, I had already tried the *NONE on the Destination options and I got the same results. What does your configuration file look like for the Xinetd.d service? Does yours look anything like ours? Here is ours: service printer { socket_type = stream protocol = tcp wait = no user = lp server = /usr/lib/cups/daemon/cups-lpd disable = no } Thanks.

    Leave a comment:


  • B.Kline
    replied
    Printing from OS400 to Red Hat Linux V9 using cups

    Change: Destination options . . . . . . . . . : XAUTOQ to *NONE. the cups-lpd program might not be smart enough to do accept auto queue selection commands. That's the only difference I can see between our configurations.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Printing from OS400 to Red Hat Linux V9 using cups


    Code

    Leave a comment:


  • B.Kline
    replied
    Printing from OS400 to Red Hat Linux V9 using cups

    I didn't edit the cups-lpd file. I enabled the service from xinetd (edit /etc/xinetd.d/cups-lpd) and then edited /etc/cups/cupsd.conf I suspect that the garbled file that you opened was the binary. Would you please post the output from dspoutqd for the queue that you're having problems with. Are you saying that the error message "Bad request line "^BCUPSPRN" is showing ON the Linux side or the AS/400 side?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Printing from OS400 to Red Hat Linux V9 using cups


    Code

    Leave a comment:


  • B.Kline
    replied
    Printing from OS400 to Red Hat Linux V9 using cups

    I just tested my hypothesis and it is correct. I configured my V4R5 system to connect to a printer configured on my laptop (Fedora Core 1) and it worked perfectly. I did have to enable the cups-lpd service to make it work. The only other issue you may run into is that if you turned on the firewall when you installed Linux then you'll need to allow lpd to pass through.

    Leave a comment:


  • B.Kline
    replied
    Printing from OS400 to Red Hat Linux V9 using cups

    I don't have a V5R2 machine to check this, but I *think* that your problem is related to the fact that using an outq to print to a remote system is done with lpr/lpd; the port for which is 515 (I don't know if V5R2 allows anything else). CUPS uses the internet printing protocol, listening on port 631. You mentioned that you don't have CUPS running on the other Linux boxen so that means that they are running lpd -- which is why they can speak with your AS/400. You can make CUPS speak lpd also by editing the file "/etc/xinetd.d/cups-lpd", ensuring that you have a line that says: disable = no (it is disable = yes, by default.) If you need to make a change then once you exit the editor issue the command: "killall -SIGHUP xinetd" to have xinetd reload the configuration. Try it once again and see if it works. The other thing that you may need to do is modify /etc/cups/cupsd.conf. The default configuration for CUPS is to disallow connections from other machines. You may need to add an "allow from" directive to give access from your domain. I can throw together a configuration to test my hypothesis, if these suggestions don't point you in the right direction.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Printing from OS400 to Red Hat Linux V9 using cups


    Code

    Leave a comment:


  • B.Kline
    started a topic Printing from OS400 to Red Hat Linux V9 using cups

    Printing from OS400 to Red Hat Linux V9 using cups

    Please post the contents of /etc/cups/printers.conf and identify which printer(s) you are attempting to print to.
Working...
X