The Perils of Activation Groups Gone Awry

RPG
Typography
  • Smaller Small Medium Big Bigger
  • Default Helvetica Segoe Georgia Times

Controversy surrounds the use of service programs in the default activation group, and this article explains a very specific and painful reason to avoid it.

 

You've probably heard that programs written for the Integrated Language Environment (ILE) don't work and play well with legacy programs written using the Old Program Model (OPM). And if you're like me, you've probably tried them together to see what would happen. This isn't something we do cavalierly; instead, it's usually in response to the needs of a real-world production development environment. You want to introduce new techniques, but you can't justify rewriting existing code just for the sake of moving it to ILE. So you end up with a mixed environment, and for the most part it works just fine. Until it breaks. Badly. This article details a very specific, very painful problem and hopefully gives you another reason to try moving those programs to ILE.

Building a Failure, One Step at a Time

The specific problem I encountered was the result of a cascade of issues. It started out simply enough: I wanted to use a CLOB in some programs. As it turned out, the routines to access the CLOB lent themselves very well to a service program, so I wrote one and began using it in lots of places. That was the first design decision in a chain of decisions that would eventually lead to a very painful system failure.

 

The second decision had to do with activation groups (AGs). I am a big proponent of *NEW and *CALLER activation groups. I know many of our esteemed colleagues in the industry like named AGs, and given the problem I'm about to describe, that may seem like a better approach. I, however, appreciate the self-cleaning nature of a *NEW AG, so that's what I chose. By doing that, it means your top-level program has *NEW as its AG, and all your supporting code pieces, whether they're in programs or service programs, use *CALLER. Specifically, I put the service program into the *CALLER AG and moved on to the next step.

 

The next step was the one that we all face: I wanted to use the service program in a legacy job stream. The high-level program is an old-fashioned CL, most of the programs in the stream are OPM programs compiled into the default activation group (DAG), and none of that is going to change anytime soon. I'm simply adding a call to the service program. The problem is this: one of the OPM programs calls an ILE program. The ILE program in turn calls the service program. This in fact has to be the case; programs compiled for the DAG cannot call service program procedures. And here's where AGs, specifically *CALLER AGs, get you in trouble.

 

The ILE program is called hundreds of times for a transaction, so it was compiled with activation group *CALLER. This means it runs in the DAG when called by an OPM program. To date, this has not been a problem, and the program has been tested extensively. It has in fact been in production for nearly five years. So despite all the warnings, nothing bad has happened…yet. But as it turns out, badness was waiting to happen.

 

The final step in building my house of cards was to add a new procedure to the service program. The procedure used an F-spec. The idea was again that this procedure would be called many times, so I took advantage of the USROPN and STATIC keywords to leave the file open between calls. This worked fantastically! I tested the system thoroughly and was able to put everything through its paces. Legacy jobs were submitted that used the system, and they ran to completion successfully. I tested all the interactive jobs, and everything ran smoothly. There really wasn't anything else to do, so we put the new programs into production.

The Phones Start Ringing

Yes indeed, within the hour the phones began to ring. Standard jobs were failing with a very nasty and cryptic error. The errors started with MCH3402 "Tried to refer to all or part of an object that no longer exists." It went on from there through several errors, finally failing with CEE9901 and ending the user's day rather unhappily. The real kicker was that none of the errors gave me a statement number in any of my programs. All the messages were going to system programs like QLEAWI and QRNXIO, so there was no way to even tell which statement was failing. It was a mess.

 

Even more disturbing was that the problem didn't affect everyone! Most of the users were working along with no problems whatsoever. It was only the power users that were having this problem. And of course, the power users are the ones most affected by system problems. We walked through exactly the steps they executed, and we couldn't cause the failure. We tested on multiple machines, in multiple environments, but nothing went wrong. We had them sign off and sign back on, and the problem went away…for a while. Eventually they'd call back and their workstation would be down again.

 

And then finally I got it to fail in test.

RCLRSC Ate My Program

The way I made the system fail was to call a menu option twice. The second time failed with the strange error. Remember, there was no HLL statement number on any of the error messages, so I didn't know which program was failing, or where. At a loss, I finally just did a STRDBG with no program and then made the problem reoccur. And lo and behold, the debug window popped up with the cursor on the ENDPGM statement of the CL. This was quite interesting; I'd never seen an ENDPGM statement fail before. But something caught my eye.

 

For historical reasons, this particular CL program did a RCLRSC just before the ENDPGM statement. Suddenly I started recalling stories and anecdotes from the early days of ILE in which RCLRSC was supposed to be bad to use with ILE and service programs in particular. After the fact, I did some more searching on the Internet and, with the right keywords, I ran across a couple of conversations explaining the problem in more detail. I fixed the problem by taking the RCLRSC out of the CL. And everything ran fine.

 

For a while.

 

Within a few hours, after assuring everyone we'd gotten to the bottom of the problem, it cropped up again. Tearing my hair out, I looked at the caller's joblog and realized something. While he was calling the menu option, he hit a command key that called a different CL that unfortunately also had one of those historical RCLRSC statements. As it turns out, any RCLRSC would cause the service program procedure with the F-spec to crash spectacularly.

 

The final answer was to change the original ILE program to use *NEW as its AG rather than *CALLER. We haven't noticed a significant performance hit yet, and I'll do some timings on it when I get some free time. We'll also have to review our position on activation groups, OPM programs, and RCLRSC to see what steps we need to take to avoid future occurrences of the issue. It's a good discussion to have, and unfortunately sometimes it takes this sort of problem to make it occur.

BLOG COMMENTS POWERED BY DISQUS